Exploring Real Data

1. The General Social Survey (GSS) data:

a.

Background:
GSS is conducted by the National Opinion Research Centre (NORC), a Social
Science Research Centre at University of Chicago, since 1972.

Purpose:
Monitor social change within the U.S. and compare U.S. with other countries.
(The Canadian version of the GSS is available through Statistics Canada).

Topics:
Sociological and attitudinal surveys regarding education, employment,
political opinion, and crime and violence.

. Data:

Open access from University of Berkley: http://sda.berkeley.edu/

Data Analysis:
Survey Documentation and Analysis (SDA) 4.0 (Newest version) Archive:
http://sda.berkeley.edu/archive.htm

I. Free web-based data analysis
http://sda.berkeley.edu/sdaweb/analysis/?dataset=gss14

Ii. Export data into a CSV file and then import the data into a preferred
statistical software for data analysis: PSPP (Free Statistical Software)

2. PSPP: https://www.gnu.org/software/pspp/
Download PSPP (e.g., PC or Mac OS): https://www.gnu.org/software/pspp/get.html



http://sda.berkeley.edu/
http://sda.berkeley.edu/archive.htm
http://sda.berkeley.edu/sdaweb/analysis/?dataset=gss14
https://www.gnu.org/software/pspp/
https://www.gnu.org/software/pspp/get.html

Part 1. Exploring the General Social Survey (GSS) data with SDA

In 2014 a survey on attitudes towards science and technology asked participants to

indicate their opinion regarding the statement: “Science and technology are making our

lives, healthier, easier, and more comfortable” as “strongly agree”, “agree”, “disagree”, or

“strongly disagree”.
Objective: Univariate Data Analysis

Type of Data: An Ordinal Categorical Data

Levels: “strongly agree”, “agree”, “disagree”, or “strongly disagree”

Steps:

1. Visit: http://sda.berkeley.edu/sdaweb/analysis/?dataset=qss14

2. Scroll down the variable tree, and click on the folder:

2014 TOPICAL MODULE: Science, Knowledge About and Attitudes Towards.

3. Select the sub-folder, the item on this survey:
BETTRLFE - SCIENCE MAKES OUR LIVES BETTER
Note: BETTRLFE is the variable name.

4. Click view: Information regarding this variable, BETTRLFE.

SDA 4.0 Selected Study: GSS 1872-2014 Cumulative Datafile

Analysis | | Create Variables | Download Custom Subset | Search  Standard Codebook Codebook by Year of Interview

Variable Selection

Tables Means Correl. matrix Comp. correl. Regression Logit/Probit
Selected: | BETTRLFE View
SDA Frequencies/Crosstabulation Program
Copy to: | Row | Col || Ctrl || Filter Help: General / Recoding Variables
Mode: Append ®Replace Row: (Required)
Column:
» @ 2012 TOPICAL MODULE: Jewish Identity
» @ 2012 TOPICAL MODULE: Generosity ~ Control:
» @ 2012 TOPICAL MODULE: Workplace Violence
» @ 2012 TOPICAL MODULE: Science Selection Filter(s):
X : ;gz Eg:git mggﬂtz gx:ﬁ;';’“s Weight: COMPWT - Composite weight: WTSSALL * OVERSAMP * FORMWT | =
v @ 2012 TOPICAL MODULE: SKINTONE .
v @ 2012 ISSP MODULE: GENDER » Output Options
» @ 2014 TOPICAL MODULE: The Quality of Working Life .
» @ 2014 TOPICAL MODULE: Employee Compensation i
» @ 2014 TOPICAL MODULE: Altruism » Decimal Options
+ @ 2014 TOPICAL MODULE: Science, Knowledge About ar
L EENRIFES SCIENCE MAKESIOURILIVES EETES
» @ 2014 TOPICAL MODULE: Shared Capitalism Run the Table | | Clear Fields

» @ 2014 TOPICAL MODULE: National Identity Il
¢+ @ 2014 TOPICAL MODULE: Citizenship
+ @ 2014 TOPICAL MODULE: WORK AND RELATIONSHIF

List values


http://sda.berkeley.edu/sdaweb/analysis/?dataset=gss14

5. Quick overview, frequency distribution, of the variable, BETTRLFE.

BETTRLFE SCIENCE MAKES OUR LIVES BETTER
Description of the Variable

I0m going to read to vou Some Statements like those yvou might

find in a newspaper or magazine article. For each statement, pleasze
tell me if you strongly agree, agree, disagree, or strongly di=zagree.
C. Science and technology are making our lives, healthier, easier, and
more comfortable.

Percent N Value Label
18.5 225 1 Strongly agree
63.4 172 2 Agree
16.5 201 J Disagree

16 19 4 Strongly disagree
268,360 0 AP
20 8 Don't know
2 9 No answer
100.0 59,599 Total
Properties

Data type: numeric

Missing-data codes: 0,69

Mean: 2.01

Std Dev: 64

Record/column: 1/4772

Selected Study: General Social Survey Cumulative Datafile 1972-2014



6. Making some changes to SDA options and then running the table:

[Analysis ‘ [0reate Variables l [ Download Custom 5uhsetl l Search] Standard Codebook Codebook by Year of Interview

Variable Selection ]
Selected {BETTRLFE ? ]

» @ 2014 TOPICAL MODULE: The Quality of Working Life
» @ 2014 TOPICAL MODULE: Employee Compensation

2014 TOPICAL MODULE: Mational Identity Il

2014 TOPICAL MODULE: Citizenship

2014 TOPICAL MODULE: WORK AND RELATIONSHIF
2014 TOPICAL MODULE: HIGH RISK BEHAVIORS
1985-1990 1SSP MODULE - PRESS FREEDOM VS GO
19356 ISSP MODULE: SOCIAL SUPPORT AND NETWC
1987 15SP MODULE: SOCIAL INEQUALITY

1958 ISSP MODULE: WOMEN AND WORK

1989 158P MODULE: WORK ORIENTATION

1991 ISSP MODULE: RELIGION

1993 I15SP MODULE: ENVIRONMENT

PERSONAL IMPACT OF PUBLIC CONCERNS

IV VU NEVERNEEN

RECENT PROBLEMS FOR RESPONDENT i
< >
copy vo: | Sgliel e[S
Mode: () Append @ Replace
0 ISSH MODULE: ENVIRONMEN
0 SCIENCE (New) A

0 NIOSH (NEC)
2 TOPICAL MODULE: Jewish Identity
2 TOPICAL MODULE: Generosity
2 TOPICAL MODULE: Workplace Violence
2 TOPICAL MODULE: Science
2 TOPICAL MODULE: Miscellaneous
2 TOPICAL MODULE: Experiment
2 TOPICAL MODULE: SKINTOMNE
2 ISSP MODULE: GENDER
4 TOPICAL MODULE: The Quality of Working Life
4 TOPICAL MODULE: Employee Compensation
4 TOPICAL MODULE: Altruism
4 TOPICAL MODULE: Science, Knowledge About and Atiitudes
4 TOPICAL MODULE: Shared Capitalism
4 TOPICAL MODULE: Mational Identity Il
4 TOPICAL MODULE: Citizenship [V
4 TOPICAL MODULE: WORK AND RELATIONSHIFS
< >

P

Help: General / Recoding Variables

Row: BETTRLFE | (Required)

Column; |

Control: [ |

Selection Filter(s): |
—
Weight: No Weight )

Cell contents:

Percentaging: E Column D Row D Total

Sample design: @Cumpl&){ OSRS

D Confidence intervals - Level:95 percent V|

D Standard error of each percent
D Design effect (deft) for each percent Dl-statistics

. |Unweighted N ¥ weighted N

E Color coding
e missing-data values

kes Our Lives Better 5 ]

oy

» Output Options
4_.
Type of chart [FEIS =0 v |
e ——

General Chart Options

" Show percents
Palette: @ Color O Grayscale

Size - width: height:

Bar Chart Options

Orientation: (@) vertical () Horizontal

Visual Effects: (®)2.0( 3D

» Decimal Options

Run the Table | Clear Fields




7. After we run the table, for valid cases (n = 1217), this is (part of) the SDA output:

Science Makes Our Lives Better
SDA 4.0: Tables
General Social Survey Cumulative Datafile 1972-2014
Aug 20, 2016 (Sat 01:36 PM PDT)
Variables
Role Name Label Range  MD Dataset
Row BETTRLFE SCIENCE MAKES OUR LIVES BETTER 14 (089 1

Fioaf g sl e ] SCIENCE MAKES OUR LIVES BETTER
Cells contain: 85
-Column percent Distribution 50
-N of cases 55
, 18.5 2y
1- Strongly agree 225 45
63.4 £
2. Agree ?7:2 g 3>
&
BETTRLFE 3- Disagree 16.5 -
- Disag 201 20
1 6 15
4: Strongly disagree 1'9 10
5
100.0 0
COL TOTAL 1217

|l Strongly agree M Agree M Disagree m Strongly disagree

e We can prompt students with questions such as:
¢ What was the most response to this GSS statement? Answer: Agree
e \We can develop students’ numeracy skills:

e Leave the total count (e.g., 1217) and the percentages for each category (e.g.,
18.5%, 63.4%, 16.5%, 1.6%).

¢ Hide the frequencies (e.g., 225, 772, 201, 19) in the frequency distribution.
e Ask students, “how many participants agreed to this GSS question?”

Take the percentage in the “agree” category and multiply by the total count:

63.4% (or 0.634) x 1217 = 772



8. Treat an ordinal categorical variable as a quantitative variable:

Objective: Obtain summary statistics such as the Mean, Median, Mode, and
Standard Deviation.

Science Makes Our Lives Better
SDA 4.0: Tables
General Social Survey Cumulative Datafile 1972-2014
Aug 20, 2016 (Sat 01:36 PM PDT)
Variables
Role Name Label Range MD |Dataset
Row BETTRLFE SCIENCE MAKES OURLIVESBETTER 14 0,89 1

Frequency Distribution
Cells contain:
-Column percent Distribution
-N of cases
i 18.5
1: Strongly agree 295
) 63.4
2. Agree 772
. 16.5
BETTRLFE 3: Disagree 201
4: Strongly disagree 113
100.0
COL TOTAL 1.217

e We can prompt students with questions such as:

¢ \WWhat is the mean response to this GSS statement?

¢ \WWhat is the median response to this GSS statement?

e What is the mode response to this GSS statement?

e What is the shape of the distribution to this GSS statement?

e Find the mean in two different ways (some rounding are involved):

1. Mean = sum(level x frequncy of that level) - 1(225)+2(772)+3(201)+4(19) _ 2448 — 201

total count 1217 1217

2. (Weighted) Mean = sum (level x proportion for each level)
=(0.185x 1) + (2 x 0.634) + (3 x 0.165) + (4 x 0.016) = 2.03



e Find the median, 50" percentile:
Add percentages until we reach 50%. In this example:
18.5% (less than 50%; so add the next %) + 63.40% > 50% (median is here).
Median is 2 (refers to “agree” category).

e Mean is very close to the median (slightly bigger):

(Mean = 2.01) = (Median = 2)
~ We have an approximately symmetrical distribution.

e Mode refers to the most frequent category. In this example, it is level 2 (refers to
“agree” category).

Mean, Median, and Mode are about the same.
~ We have an approximately, bell-shaped symmetrical distribution.

Below is what SDA provides as summary statistics:

Summary Statistics

Mean = 201 StdDev= 64 Coefvar= 32
Median = 2.00 Variance = .41 Min = 1.00
Mode = 200 Skewness = 34 Max = 4 00

Sum= 244800 Kurtosis = .50 Range = 3.00

9. SDA provides information regarding how the data were collected:

Sample design: stratified cluster sample

Stratum variable = SAMPLERC
Cluster variable = RSAMPCODE



Consider, adding a layer to the data analysis. In this example, we will add the
variable sex of respondents into the data analysis.

Objective: Bivariate Data Analysis (Association between Two Categorical Variables)
Variables and their Type:
e Opinion About Science Make L.ife Better:
An Ordinal Categorical Variable
Levels: “strongly agree”, “agree”, “disagree”, or “strongly disagree”
¢ Sex of respondents:
A Nominal Categorical
Levels: “Male”, or “Female”

10. Select “SEX” as the “Row” Variable; And, “BETTRLFE” as the “Column”
variable. Follow the screen shots below to makes the changes to SDA and then click
on “Run the Table”.

SDA 4.0 Selected Study: GSS 1872-2014 Cumulative Datafile
‘Analysis“(:reate Variables”l: (o4 ‘ I ‘ Standard Codebook Codebook by Year of Interview
- N : Gen ing Vari
[Varlable selection l Help: General / Recoding Variables
o Y
Seleded:‘SEx ) ”Vim Row: SEX | (Required)
‘j - Column: BETTRLFE |
Copy to: | Row | Col || Ctrl || Filter
- Control: |
Mode: () nd @ Replace
9 Append @Rep Selection Filter(s): | |
. Weight: [No Weight L=
~
- RESPONDENT BACKGROUND VARIABLES
~ @ Age, Gender, Race, and Ethnicity
™ AGE - AGE OF RESPONDENT Cell contents:

'- =t Sy Percentaging: DCqum @ Total
[ RACECENT - WHAT IS RS RACE 15T MENTION

® RACECENZ - WHAT IS RS RACE 2ND MENTION Sample design: @) complex /SRS

[ RACECEN3 - WHAT IS RS RACE 3RD MENTIOM . |

[ HISPANIC - HISPANIC SPECIFIED " Confidence intervals - Level{ 35 percent v|

™ RACEHISP - Race with Hispanic (2000 and later) D Standard error of each percent

[ ETHNIC - COUNTRY OF FAMILY ORIGIN D Design effect (deft) for each percent DZ_suatistics
[ ETH1 - 1ST MENTIONED COUNTRY OF ORIGIN N N

[ ETH2 - 2ND MENTIONED COUNTRY OF ORIGIM " Unweighted N ¥/ weighted N

[ ETH2 - 3RD MENTIONED COUNTRY OF ORIGIM
[ ETHNUM - TYPE OF RESPONSE ABOUT ETHNI a s @ T
@ SPETHNIC - COUNTRY OF SPOUSES FAMILY ¢ Summary statistics **/Question text *J Color coding

@ SPETH1- 1ST MENTIONED COUNTRY OF SPO D Suppress table Dlnclude missing-data values
O SPETH2 - 2ND MENTIONED COUNTRY OF SPC
< >

Moge: () Append @ Replace ﬁiﬁl .
Type of chart{ |Bar Chart v.

Other options:

itle: | Distibution of Gender bly Opinion About Science Make Life Better

» @ CASE IDENTIFICATION AND YEAR A
~ @ RESPONDENT BACKGROUND VARIABLES General Chart Options
= @ Age, Gender, Race, and Ethnicity || Show percents

O AGE - AGE OF RESPONDENT -
o Palette: (&) Color () Grayscale
O RACE - RACE OF RESPONDENT o )
[ RACECENT - WHAT IS RS RACE 1ST MENTION Size - width: height
O RACECENZ - WHAT IS RS RACE 2ND MENTION
™ RACECEN3 - WHAT IS RS RACE 3RD MENTION Bar Chart Options
O HISPANIC - HISPANIC SPECIFIED o
[ RACEHISP - Race with Hispanic (2000 and later) Orientation: (@) vertical () Horizontal
O ETHNIC - COUNTRY OF FAMILY ORIGIN
O ETH1 - 1ST MENTIONED COUNTRY OF ORIGIN Visual Effects: (®)2-0( )30
O ETH2 - 2ND MENTIONED COUNTRY OF ORIGIK
O ETH3 - 3RD MENTIONED COUNTRY OF ORIGIh
O ETHNUM - TYPE OF RESPONSE ABOUT ETHNI ‘ » Decimal Options
O SPETHNIC - COUNTRY OF SPOUSES FAMILY ¢
© SPETH1 - 15T MENTIONED COUNTRY OF SFO " -

O SPETH2 - 2ND MENTIONED COUNTRY OF SPC
>




11.The contingency table for the distribution of:

“Opinion About Science Makes our Lives Better by Sex of Respondents™.
Distibution of Gender by Opinion About Science Make Life Better
SDA 4.0: Tables

General Social Survey Cumulative Datafile 1972-2014
Aug 21, 2016 (Sun 03:35 PM PDT)

Variables
Role Name Label Range MD Dataset
Row SEX RESPONDENTS SEX 1-2 0 1

Column BETTRLFE SCIENCE MAKES OUR LIVES BETTER | 1-4 0,89 1

Frequency Distribution

BETTRLFE
Comanan T
-N of cases S;Errégew Agree Disagree g’ggg%; TOTAL
e B
SEX 2: FEMALE R R ' I
cotorar o O i e it

Color ceding: =~ <20 <10 <00 =00 =10 =20 7

N in each cell:  Smaller than expected | Larger than expected

We can develop students’ statistical literacy (read and interpret the table):

e Marginal Distributions:
- E.g., percentage of male respondents: 543/1217 x 100 = 44.61%

e Conditional Distributions:
- Percentage of male participants who agreed: 331/543 x 100 = 60.96%;
- Percentage of female participants who agreed: 441/674 x 100 = 65:48%
- Compare the percentages for males and females who agreed:
Female participants were more likely to agree than the males.

e Joint Distributions:
- E.g., percentage of the participants who were male and agreed to the GSS
statement: 331/1217 x 100 = 27.20%
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12.The nested bar chart for the distribution of:

“Opinion About Science Makes our Lives Better by Sex of Respondents™.

SCIENCE MAKES OUR LIVES BETTER BY RESPONDENTS SEX
B5 1
B0 1
55
50 1
45
= 40
E 35
o 30
25 1
20 1
15 -
10
5

0- : :

wpE %gw"-ﬁ

|l Strongly agree W Agres M Disagree W Strongly disagree|

We can ask students to describe any obvious pattern they see in the graph.
Graph interpretation:
Both male and female participants mostly agreed to the GSS statement, “Science

and technology make our lives better”. More of the female respondents agreed to
the GSS statement than the males.
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Export Data into a CSV file

1. In SDA, from the tool bar menu, go to “Download Custom Subset”.
2. Inthe “File Options™ tab, select “CSV file from the “Type of data file to create”.

SDA 4.0 Selected Study: GSS 1972-2014 Cumulative Datafile
[Analysis‘ [create Variables {Eownload Custom Subseﬂ Seamhl Standard Codebook Codebook by Year of Interview

[ Variable Selection

Selected: | || view

+ [@ CASE IDENTIFICATION AND YEAR
+ @ RESPONDENT BACKGROUND VARIABLES
+ @ PERSONAL AND FAMILY INFORMATION
+ [@ ATTITUDINAL MEASURES - NATIONAL PROBLEMS
+ @ PERSONAL CONCERNS

+ @ SOCIETAL CONCERNS

+ @ WORKPLACE AND ECONOMIC CONCERNS

+ @ CONTROVERSIAL SOCIAL ISSUES

+ @ MILITARY ISSUES

+ [@ OBLIGATIONS AND RESPONSIBILITIES

b 1985 TOPICAL MODULE: SOCIAL NETWORKS

b 1987 TOPICAL MODULE: SOCIQO-POLITICAL PARTICH
b 1988 TOPICAL MODULE: RELIGION

3 1890 MODULE: INTER-GROUP RELATIONS

: 1891 TOPICAL MODULE: WORK ORGANIZATIONS

. 1007 1990 JMON I E- ST THRE

inuwww

| File Options H Select Cases H Select Variables H Create Files

[ Custom Subset: Select the FILE to Construct

Complete the options on each tab. After you have chosen the files, cases and variables you want to include in your subset, you can create the
files and download them on the last tab.

Type of data file to create:

(_) Text file with no extra blanks

ext file with

C3V file (Comma Separated Values with header record)

Codebook:

E Codebook for subset data (ASCII)

Data definitions for:

[ Isas [ lspss [ Istata | 'poigxmyy [ /spambn

3. In “Select Variables” tab, under “Specify individual variables names”, type in the box
the names of the two variables: SEX, BETTRLFE.

IAnalysis‘ [create Variables” Download Custom suhset| [saarcn‘ Standard Codebook Codebook by Year of Interview

I Variable Selection

l

Selected: | View

@ RESPONDENT BACKGROUND VARIABLES

@ PERSONAL AND FAMILY INFORMATION

(@ ATTITUDINAL MEASURES - NATIONAL PROBLEMS
(@ PERSONAL CONCERNS

(@ SOCIETAL CONCERNS

@ WORKPLACE AND ECONOMIC CONCERNS

@ CONTROVERSIAL SOCIAL ISSUES

@ MILITARY ISSUES

@ OBLIGATIONS AND RESPONSIBILITIES

1985 TOPICAL MODULE: SOCIAL NETWORKS

1987 TOPICAL MODULE: SOCIO-POLITICAL PARTICII
1988 TOPICAL MODULE: RELIGION

1990 MODULE: INTER-GROUP RELATIONS

1991 TOPICAL MODULE: WORK ORGANIZATIONS
1993 ISSP MODULE: CULTURE

== 1004 FAMIV KANRI ITV MANI I E

L T T T

FY YT YT YTETTTTOTTETYTY Y

@ CASE IDENTIFICATION AND YEAR ~

e
‘ File Options || Select Cases ||i Select Variables H Create Files

[ Select VARIABLES to include in subset:

You can specify up to 1000 variables to include in the subset. (Note: the CASEID variable is always automatically included in the subset as the
first variable.)

Specify individual variable names:

One - way thal variables can be selected for inclusion in the subset is by entering their names in the text box below. These variables can be
Ies set up with the dataset or variables created by RECODE or COMPUTE.

SEX
BETTRLFE

Select variables from groups:

To select more than a few variables, you will probably want to use the variable selection tree. Note that the tree only displays original variables.
If you want to include variables created by RECODE or COMPUTE, specify them individually in the text box and they will be combined together
with the variables selected from the tree in your subset. Click on the Display Variable Selection Tree button below to begin selecting variables
from the tree.

Display Variable Selection Tree
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4. In “Create Files” tab, click on the icon “Create Files”.

5. Next, click on the icon “Data files’ and save the data in your “My Document” folder.

6. Click on the icon “Codebook”. Note the numeric references for the levels of the
variables in the data file:

SEX: “1 = Male”, “2 = Female”
BETTRLFE: “1 = Strongly Agree”, “2 = Agree”, “3 = Disagree”, “4 = Strongly Disagree”

The above levels for each variable are the only levels we want to include into our data
analysis. We will omit the missing values coded as, e.g., 8, 9, from our data analysis (later
on in PSPP).

SDA 4.0 Selected Study: GSS 1872-2014 Cumulative Datafile
Analysis || Create Variables |Download Custom Subset| | Search Standard Codebook Codebook by Year of Interview

Variable Selaction File Options Select Cases Select Variables Create Files

Selected: View

Check Subset Specification and Create Files

The subset options you have specified are listed below. Please check that they are correct before continuing. If the specifications are NOT
correct, back up to the appropriate tab and correct your entries. If the specifications are correct, just press the "Create Files” button below.
(Please be patient if the original data file is large.)

File(s) to create:

+ Data file: CSV file (Comma Separated Values with header record)
» @ CASE IDENTIFICATION AND YEAR A + Codebook

+ @ RESPONDENT BACKGROUND VARIABLES

» @ PERSONAL AND FAMILY INFORMATION

» @ ATTITUDINAL MEASURES - NATIONAL PROBLEMS
» @ PERSONAL CONCERNS

» @ SOCIETAL CONCERNS

» @ WORKPLACE AND ECONOMIC CONCERNS

» @ CONTROVERSIAL SOCIAL ISSUES

» @ MILITARY ISSUES

» @ OBLIGATIONS AND RESPONSIBILITIES

+ @ 1985 TOPICAL MODULE: SOCIAL NETWORKS 3 variables for 59599 cases in subset.
» @ 1987 TOPICAL MODULE: SOCIO-POLITICAL PARTICII Data
» @ 1988 TOPICAL MODULE: RELIGION

» @ 1990 MODULE: INTER-GROUP RELATIONS

» @ 1991 TOPICAL MODULE: WORK ORGANIZATIONS
» @ 1993 ISSP MODULE: CULTURE

» @ 1994 FAMILY MOBILITY MODULE

» @ 1994 MULTICULTURALISM MODULE (¥ 4+ Zip archive - ALL files
» @ FAMILY - FINANCES - DONATIONS

< >

Filter(s) to select cases: [None specified]

Show List of All Variables Selected for Subset

bsetting is now complete. Click on the button(s) below to view and/or download the file(s) to your computer.

4 Codebook

Ve containing ALL of the subset files has also been created. You can download it, instead of the individual files, below:



Part 2. Import Data in PSPP
s Open PSPP.
1. Select Files to Import:

* In menu bar, go to File > Import Data > My Document
o Select the saved data file
e Click Next (Bottom of the page)

2. Select the Lines to Import:
= Click Next
3. Select the First Line:
= Select Line “1”
= Check off the box: Line Above Selected Line Contains Variable Names
= Click Next
4. Choose Separators:
= Click Next
5. Adjust Variable Formats:
= Click Apply.
% Go to Variable View (Bottom of the page).

= For variable SEX, make value labels:
o Value: 1, Value Label: Male; Click on Add
o Value: 2, Value Label: Female; Click on Add
o Click Ok.

= For variable BETTRLFE, make value labels:

o Value: 1, Value Label: Strongly Agree; Click on Add
Value: 2, Value Label: Agree; Click on Add
Value: 3, Value Label: Disagree; Click on Add
Value: 4, Value Label: Strongly Disagree; Click on Add
Click Ok.

O O O O



% In menu bar, go to File > New > Syntax
= Copy the syntax below and paste into the syntax editor:

SELECT IF (SEX = 1 OR SEX = 2).
EXECUTE.

SELECT IF (BETTRLFE =1 OR BETTRLFE =2 OR BETTRLFE =3 OR
BETTRLFE = 4).
EXECUTE.

= In the syntax menu bar, click on RUN > ALL.

+* In menu bar, go to Bar Chart.

= In the Bar Chart box that appears:

e Variable: BETTRLFE
e Variable Axis: SEX
e Variable Cluster: BETTRLFE
e Click OK.
s PSPP output:
Bar Chart
[] Strongly
4004 [] Agree
350+ [] Disagre:
300+ [ Strongly
2 50—
200
150
100—
% 50—
(]
U G 1 1
Male Female

SEX

14



 In menu bar, go to Analyze > Descriptive Statistics > Crosstabs

= In the Crosstabs box that appears:

+» PSPP output:

b CROSSTARS

e Rows: Select variable “SEX”

e Columns: Select variable “BETTRLFE”

e Click OK.
CROSSTABS
CROSSTABS
TABLES= SEX  BY BETTRLFE

JFORMAT=AVALLIE TAEBLES PIVOT

JETATISTICS=CHIZD
JCELLS=COUNT ROW

COLLIME TOTAL,

SUMImary,
Cases
valid [Missing Total
[ | Percent | M| Percent [+ | Percent
SEX *+ BETTELFE | 1217 | 100.0% | O 0.0% | 1217 | 1o0.0%%

SEX * BETTRELFE [count. row %, column %, total %6].

BETTRLFE
SEX | Strongly Agree | Agree Disagree | Strongly Disagree Total
[Male 120.00 331.00 52.00 10,00 543.00
22.10% 50,95% 15.10% 1.84% | 100.00%
53.33% 42.82% 40,80% S2.63% 44 .52%
O,56% 27 .20% 5.74% 2% 44 .62%
Fermnale 105.00 441,00 115,00 9,00 574,00
15,58% G5 43% 17, 66% 1.24% | 1o00.00%
45,67% 57.12% 59.20% 47.37% 55.38%
2.53% 35.24% 9.78% TA% 55.38%
Total 225,00 772,00 201.00 19.00 121700
12.49% 53.43% 15.52% 1.55% | 100.00%
100.00% | 100.00% | 100.00% 100.00% | 100.00%
12.49% G2 43% 16.52% 1.568% | 100,00%
Chi-square tests,
Statistic Value | df | Asymp. Sig. (2-tailed)
Pearson Chi-Square o255 3 023
Likelihood Ratio 950 | 3 023
Linear-by-Linear Association 474 | 1 JE0
I oof valid Cases 1217

15



%+ Options to save (Export) PSPP outputs:

* In the output window, go to File > Export > “Give a name to your output”
= At the bottom of the box that appears, from the drop down menu, select the format

that you want to save your PSPP output: e.g., HTML(*.html)

= Click “Save”

Here is the PSPP output in html format:

SEX * BETTELEFE [count. row %. column %, total %a].

BETTRLFE
SEX| Strongly Agree| Agree |Disagree|Strongly Disagreq Total
Male 120.00{ 33100 82.00 10.00f 343.00
22.10%| 60.96%| 15.10% 1.84%(100.00%
53.33%| 42.88%| 40.80% 52.63%| 44.62%
9 86%| 27.20%| 6.74% 82%)| 44.62%
Female 105.00{ 441000 119.00 000/ 674.00
15.58%| 63.43%| 17.66% 1.34%(100.00%
46.67%| 37.12%)| 59.20% 47.37%| 55.38%
8.63%| 36.24%| 9.78% T4%| 55.38%
Total 225000 772.00[ 201.00 19.00( 1217.00
18 49%| 63.43%| 16.52% 1.56%(100.00%
100.00%(100.00%|100.00% 100.00%(100.00%
18 49%| 63.43%| 16.52% 1.56%(100.00%

+»» PSPP Codes:

ELECT IF (SEX =1 OR SEX = 2).

EXECUTE.

SELECT IF (BETTRLFE =1 OR BETTRLFE =2 OR BETTRLFE =3 OR

BETTRLFE = 4).
EXECUTE.

GRAPH /BAR = COUNT BY SEX BY BETTRLFE.

CROSSTABS

ITABLES= SEX

BY

/[FORMAT=AVALUE TABLES PIVOT
ISTATISTICS=CHISQ
/CELLS=COUNT ROW COLUMN TOTAL.

BETTRLFE



~ The End ~
Thanks for your participation ©

Asal Aslemand



